Example BPMN process does not deploy


#1

I’m new to Camunda and following the Getting Started tutorial. After copying the WAR file to the webapps folder, I checked catalina.2017-05-11.log (I don’t have a catalina.out file). The only entries related to the example loan-approval process are below. There is no indication that the deployment was successful, only that it finished. Also, Cockpit only shows the demo Invoice Receipt process and not the loan-approval process, so apparently I did something wrong, but I don’t what. I’d be grateful for any suggestions. Thanks, Darin.

FYI: My environment is Win 7 Pro, Eclipse Neon.3, Java EE IDE, camunda-bpm-tomcat-7.6.0.

11-May-2017 16:42:03.837 INFO [localhost-startStop-2] org.apache.catalina.startup.HostConfig.deployWAR Deploying web application archive C:\Users\DD3194\Documents\Camunda\server\apache-tomcat-8.0.24\webapps\loan-approval-0.1.0-SNAPSHOT.war
11-May-2017 16:42:06.001 INFO [localhost-startStop-2] org.apache.jasper.servlet.TldScanner.scanJars At least one JAR was scanned for TLDs yet contained no TLDs. Enable debug logging for this logger for a complete list of JARs that were scanned but no TLDs were found in them. Skipping unneeded JARs during scanning can improve startup time and JSP compilation time.
11-May-2017 16:42:06.005 INFO [localhost-startStop-2] org.apache.catalina.startup.HostConfig.deployWAR Deployment of web application archive C:\Users\DD3194\Documents\Camunda\server\apache-tomcat-8.0.24\webapps\loan-approval-0.1.0-SNAPSHOT.war has finished in 2,169 ms


#2

Hi Darin,

please post your related process model (bpmn file), perhaps you miss the isExecutable flag.

Greets
Chris


#3

Chris,

loan request diagram.bpmn (3.0 KB)

isExecutable flag is enabled.

Thanks, Darin


#4

Hi Darin,

sorry for the late response.
How does your WAR archive look like?

Greets,
Chris


#5

Chris,

I’m not sure how to answer that question precisely. I posted the war file here if you want to take a look at it. If there is other information I can provide to help diagnose what is happening, please let me know.

Thanks for your assistance,
Darin


#6

Hi Darin,

Is it possible that you forgot to add a ProcessApplication and the processes.xml?

  1. Step: Add an Process App

    @ProcessApplication(“Loan Approval App”)
    public class LoanApprovalApp extends ServletProcessApplication {
    }

  2. Step: Place the processes.xml file in the resources/META-INF folder
    If you want versioning set isDeleteUponUndeploy to false.

processes.xml (456 Bytes)

Hope that solved your issue.
Please let me know :slight_smile:

Kind regards,
Dominik


#7

Dominik,

  1. Confirmed. The process app is defined:

[continued in next reply due to limitation of one image per post…]


#8

[continued from previous reply]

2 - Confirmed. processes.xml file is in resources/META-INF folder:

From inspection of catalina.2017-05-18.log (5.5 KB), I noticed that the entry “Detected @ProcessApplication class” appears for the camunda-invoice process but not for the loan-approval process. This is a clue that something is wrong, but I don’t know what specifically is causing it.

Another other ideas? Thanks!
Darin


#9

Hi,

The WAR Archive, which you have posted, has no process application.

This is the content of your archive:

META-INF/
META-INF/MANIFEST.MF
WEB-INF/
WEB-INF/classes/
WEB-INF/classes/loan request diagram.bpmn
META-INF/maven/
META-INF/maven/org.camunda.bpm.getstarted/
META-INF/maven/org.camunda.bpm.getstarted/loan-approval/
META-INF/maven/org.camunda.bpm.getstarted/loan-approval/pom.xml
META-INF/maven/org.camunda.bpm.getstarted/loan-approval/pom.properties

Make sure that you build the WAR archive right, so it contains the files which are mentioned by @dominikh.

Greets
Chris


#10

Hi Darin,

I think you should place the ProcessApplication in the main.java package.
Because it looks like your class is not on the Java build class path.

Greetings,
Dominik


#11

Dominic and Chris,

Thank you for the pointers. I used Windows Explorer to move the “org\camunda\bpm\getstarted\loanapproval” tree under src\main\java. This led me to define JDK as the default execution environment under Window > Preferences > Java > Installed JREs. With these changes, “Run As > Maven Install” succeeded in building a war file that deployed successfully.

My confusion / frustration is that the tutorial makes certain assumptions (without saying so) about how Eclipse is configured. Without that configuration, the demo won’t build.

Regardless, I’m able to move forward now. Thanks again for your assistance!
Darin


#12

Hi Darin and other guys.
I am facing exactly the same problem as yours here and my question is at the point where you mention that you define JDK as the default execution environment at Installed JREs. When I click at Installed JREs I see 13 execution environments with jre1.8.0_131 as their compatible JRE. I select this jre (1.8.0_131) but I can not see a difference when I select Run As > Maven Install for the building of a war file that can be deployed successfully.
Thank you in advance.


#13

Hi @steftriant,

you should add one more with the path to jdk and select it.
Path should be something like C:\Program Files\Java\jdk1.8.0

regards,
Dominik


#14

Hi dominikh,
I can not understand exactly the idea of the path and what I should add to it. I will upload here 3 photos from my eclipse window in order to see what I have done. Although I have jdk1.8.0_131 installed on my computer, the 2nd error (as you can see in one of the photos) mentions this: “Dynamic Web Module 3.0 requires Java 1.6 or newer”. As for the 1st error it mentions that the certain jar file in project “loan-approval” cannot be read or is not a valid zip file and that this problem has to do with Build Path. Because I am not an expert at programming, you may explain to me in simple words.
Thank you a lot.

Steve


#15


#16

Hi @steftriant

Just go to Installed JREs not to Installed JREs -> Execution Environments.
There you can add a JRE. As the Directory you should choose your jdk path not your jre path.
As I mentioned before the path should be something like C:\Program Files\Java\jdk1.8.0

If this doesn’t help check Java -> Compiler. Maybe this is configured to Java 1.6 -> than change it to 1.8

regards,
Dominik


#17

Hi dominikh,
I followed your last instructions and the deployment of the process was successful. The problem was the selected jre path, you were right there.
I hope not to have any other questions in the future.
Thanks a lot for your help, very kind of you!

Regards,
Steve


#18

Hi @steftriant

You are welcome!
Feel free to post problems you can not solve :slight_smile:


#19

Hi dominikh,
I have been still working on the tutorial example (GET STARTED WITH BPMN 2.0) of the site and today I encountered 2 other problems.
The first one is in the paragraph “Work on the Task” (in the link “Deploy and Test”). In particular, I selected the task and clicked on the Diagram tab but for some reason the process diagram highlighting the User Task was not displayed to me although I had designed it in the Modeler. Nevertheless, I selected the Form tab, clicked on “Load Variables” and pressed “Complete”. I read the message that the assigned task was disappeared after that.
The second one is in the the paragraph “Re-Build and Deploy” (in the next link “HTML Forms”). In particular, I selected the “loan-approval” project and selected Run As–>Maven Clean as it is mentioned. After that, I tried to perform again the Maven Build but when I selected Run As–>Maven Install, I read the following error message on my Console: "COMPILATION ERROR: No compiler is provided in this environment. Perhaps you are running on a JRE rather than a JDK? BUILD FAILURE.
I checked at my Installed JREs and I have the same Directory path (C:\Program Files\Java\jdk1.8.0_131\jre) as the default JRE Definition.
I didn’t see a new WAR file of course like in the first deployment.
I hope to be clear to you.
Thanks a lot again.
Regards,
Steve


#20

Hi @steftriant

You are not logged in with the demo user right?
I think you forgot to do the following. You have to add an authorization to the user you log in with.

Please check your Project properties. Maybe there is an other configuration for the Java Compiler.
You could also check the Maven Run Configurations of your Project (right click Run AS -> Run Configurations) Perhaps there is an other JRE configured.

regards,
Dominik