WebApp Installation Issue


#1

Dear Community,
I’m currently trying to deploy the WebApp WAR file to the tomcat server. I’ve done it as described in the general install guide (https://docs.camunda.org/manual/7.5/installation/standalone-webapplication/) - but I always receive an HTTP 404 Error with the description, that the resource is not available.

I visit the url: http://localhost:8080/camunda

  • WAR file is saved in WebApps folder

any ideas?

BR
Lukas


#2

Hi Lukas,

Did you follow this instruction in the guide?

Note: If you install the Camunda standalone web application on Apache Tomcat by dropping it in the webapps folder, Tomcat will assign the filename of the war file as the context path. If you want the context path to be /camunda, rename the war file to camunda.war.

Cheers,
Thorben


#3

Yes I did, may there be a complication with the Tomcat version? I have installed v7


#4

Here for info (maybe it helps) the log while starting the Tomcat server…

Capture


#5

Does any of the log files provide the reason why camunda.war cannot be deployed?


#6

Where can I check further logs? Here in this one it is already stated, that there is an error while deploying.

In the meantime I have also tried the following:

  1. delete the file from webapps folder and upload it via the manager app - still the same problem
  2. uploaded the sample.war file in the same way - this one works - so it has to be something camunda specific.

BR
Lukas


#7

Hi Lukas,

Tomcat log files can be found in ${TOMCAT_HOME}/logs. Please attach them here and I can have a look.

Cheers,
Thorben