Galera OptimisticLockingException on complete for external task


#1

I’m using camunda with a galera cluster.
When I try to complete an external task, I get the following error:

OptimisticLockingException: ENGINE-03005 Execution of ‘DELETE ExternalTaskEntity[ed5064ff-2dff-11e9-81f8-1803734e3d3e]’ failed. Entity was updated by another transaction concurrently.

Is this related to wrong Galera cluster configuration? (the config respects the indications doc )
Or the complete is not supported for this case?


#2

Hi @Cosmin,

refer to this post to make sure that your ExternalTasks are configured properly. When using multiple ExternalTask clients set maxTasks value to 1. - Multiple External Task Client instances

Hope that helps

Regards
Michael


#3

Hey @MichiDahm,

The flow worked for a single instance of MariaDB.
When I switched to the Galera cluster, this issue started to occur.

The issue you described, the worker tried to complete the task, but he already lost his lock.
In my case, it’s a db related issue.

Either way, thanks for the reply :slight_smile:

Best regards,
Cosmin