Configure camunda optimize

I signed up for Camunda Enterprise Beta to try Optimize for 30 days and I am unable to start optimize, I am getting some errors, could you help me?

I did the following step by step:

  1. Download ElasticSearch 6.8.0
  2. Download Camunda Engine Enterprise 7.11.3-ee
  3. Download Camunda Optimize 2.6.0-alpha1-production
  4. Question: the license should I copy “----- code —” or just “code” without the dashes?

I - I started elasticsearch and returned it to me:

  "name" : "z-7DYGp",
  "cluster_name" : "elasticsearch",
  "cluster_uuid" : "nmYo1_2SQnmSlb_LxglFdA",
  "version" : {
    "number" : "6.8.0",
    "build_flavor" : "default",
    "build_type" : "tar",
    "build_hash" : "65b6179",
    "build_date" : "2019-05-15T20:06:13.172855Z",
    "build_snapshot" : false,
    "lucene_version" : "7.7.0",
    "minimum_wire_compatibility_version" : "5.6.0",
    "minimum_index_compatibility_version" : "5.0.0"
  "tagline" : "You Know, for Search"

II - I started the BPM engine camunda, and usually accessed at localhost: 8080
III - I started Camunda optimize and when opening the browser and accessing http: //localhost:8090 i get error, and am redirected to http://localhost:8090/error.html

Why? How i configure optimize? I did not place my license, and received the error:

at java.base / (
Caused by: Signature length not correct: got 128 but was expecting 256

Error on Optmize:


error on browser:

thanks =)

Hi Allison,

thanks for reaching out!

Based on the Optimize log you provided it looks like there is a license stored in elasticsearch but apparently the wrong license. Did you maybe create a environment/OptimizeLicense.txt file in the Optimize distribution? If so please delete that one.

The best way to resolve that is start fresh and clear the elasticsearch indexes. To do that, stop Optimize, then stop elasticsearch and delete the data folder inside the elasticsearch directory. Alternatively just start with a fresh elasticsearch installation. Finally start elasticsearch and Optimize and access http://localhost:8090. You should get redirected properly. Then paste the whole Optimize license, including the dashed lines:

--------------- BEGIN OPTIMIZE LICENSE KEY ---------------
--------------- END OPTIMIZE LICENSE KEY ---------------

If for some reason you don’t get redirected to the license page, please try to access it directly via http://localhost:8090/license.html .

Let me know if it worked out!


1 Like

Hi Sebastian,

Sebastian, I followed the steps and is not accepting my license, says "License Key has wrong format."

Thanks =)

It seems you are using Camunda Key instead of Optimize One


Hi @Allison1

Michal_S is right. In the trial e-mail you received there are actually two different license keys.
You should scroll down a little and there you will find the second license for Optimize.


1 Like

thanks @Sebastian_Bathke this works for me =)

Hi there, I’m having the same problem as felix-mueller.

I ordered a trial license here

The mail provided by camunda included a credential set + only one license key (BEGIN/END CAMUNDA LICENSE KEY).

I used the username and password, to login in to camunda docker registry, fetched the enterprise container and started it. When entering the web UI, I’m asked to anter my license key. After clicking “Save key”, it’s telling me " Invalid license key provided: License Key has wrong format.".

What am I doing wrong here?

Hi @Andre_Lohmann,

we offer a unified license for all products now. But this license file needs a version >= 7.12 of the Camunda BPM Platform:

Hope this helps, Ingo

I get this error in optimize
Could not authenticate you, please check your credentials.
how can I fix it