Camunda upgrade 3.3.3 - 7.*.*

I am using the camunda bpm- starter version set around 3.3.3

And we see that we are facing the error which i have already posted on the forum


On looking at the jira board i figured there were some fix provided for the same in later version
https://jira.camunda.com/browse/CAM-10911

so , few queries

  1. Upgrading to latest 7.X.X wheter the issue will be fixed ?
  2. any upgrade steps from 3.3.3 to 7.X.X ?
  3. where can we get the databse scripts ?

I am more concerned on the point1 .

All of the upgrade scripts are found here and you’ll also need to take a look at the comparability chart to understand how the engine version has changed with the version of the spring boot starter.

Thanks @Niall .I hope the error which we face now would be resolved when i migrate :

Cannot create session after the response has been commited ?

I don’t really sure what could be causing that error i’m sorry to say.