Camunda Tutorial for Java Developer didnt work


#1

2 issues

#1
I tried to import the maven archetypes for camunda bpm as suggested in https://vimeo.com/235728986, using the ‘add remote catalog’ option. It said ‘Remote Catalog empty’.

#2
I created a new maven project with all pom dependencies and followed till the deployment as suggested in https://vimeo.com/235728986, the console log said simpledemo.war deployed but I couldn’t see the process in cockpit.


#2

This tends to happen in senarios where you’re behind a firewall or have a strange maven config which uses a local maven mirror.

There are a lot of reasons why this might happen, can you upload your process model so i can see if it can be deployed?


#3

For issue #1
I was referring to the archetype import in eclipse. And proxy config is fine and I am able to look up other plugins etc. How does maven config play a role on eclipse archetype import ?

For issue #2
I will attach my code with the process bpmn file. I also have a processes.xml in META-INF folder. I tried deploying with and without it but no luck. Please check and let me know.


#4

CheckWeather.bpmn (5.1 KB)


#5

processes.xml (494 Bytes)

===

I missed creating the CamundaBpmProcessApplication as I didnt have the archetype in my STS because of the above said issue.

It worked after I added this java class.

Thanks!
Mani