Camunda Full Distribution on EC2

Hi @all,

I’ve problems running camunda full distribution on an ec2 instance of Amazon aws. I’ve installed java-1.8.9-openjdk and created inbound rules for TCP 8080. After running I get:

[ec2-user@ip-172-31-23-68 ~]$ server/apache-tomcat-9.0.19/bin/
Using CATALINA_BASE: /home/ec2-user/server/apache-tomcat-9.0.19
Using CATALINA_HOME: /home/ec2-user/server/apache-tomcat-9.0.19
Using CATALINA_TMPDIR: /home/ec2-user/server/apache-tomcat-9.0.19/temp
Using JRE_HOME: /usr
Using CLASSPATH: /home/ec2-user/server/apache-tomcat-9.0.19/bin/bootstrap.jar:/home/ec2-user
Tomcat started.

But tomcat isn’t really running or I can’t connect. Get connection refused.

Do you have any ideas?


Hi, do you have access to the ec2 instance console? If so, in the console can you use a local browser to browse to localhost? If thats working, then the engine is fine and access control is your problem.

Make sure VPC set up and security group and inbound and outbound rules configuration are correct. And also make sure that port is enabled which tomcat uses.

okay, so I got the main problem. Camunda / Tomcat wasn’t able to start up cause auf a missconfigured database connection