Camunda EmbeddedForms Start button diabled


#1

Hi, I’m using embedded form in my StartEvent. After starting the process in Camunda, embedded form opened. But the start button is disabled in the form.

Below is my embedded form. Please help me why the button is disabled.

<form role="form" name="form" class="form-horizontal">
  <div class="form-group">
    <label class="control-label col-md-4"
           for="goal">Goal</label>
    <div class="col-md-8">
      <input cam-variable-name="goal"
             cam-variable-type="String"
             id="goal"
             class="form-control"
             type="text"
              />    
    </div>
  </div>
  
  <div class="form-group">
    <label class="control-label col-md-4"
           for="budget">Budget</label>
    <div class="col-md-8">
      <input cam-variable-name="budget"
             cam-variable-type="Double"
             id="budget"
             class="form-control"
             type="text"
              />
      
    </div>
  </div>
  
  <div class="control-group">
    <label class="control-label">Target</label>
    <div class="controls">
      <select cam-variable-name="target"
              cam-variable-type="String"
              type="text"
              name="target"
              class="form-control"
              required>
        <option></option>
        <option value="multivariate">Multivariate</option>
        <option value="a/b">A/B</option>
        <option value="basic">Basic</option>
      </select>      
    </div>
  </div>
  
  <div class="form-group">
    <label class="control-label col-md-4"
           for="startdate">StartDate</label>
    <div class="col-md-8">
      <input cam-variable-name="startdate"
             cam-variable-type="Date"
             id="startdate"
             name="startdate"
             class="form-control"
	     type="date"
             />
    </div>
  </div>
  
  
  <div class="form-group">
    <label class="control-label col-md-4"
           for="enddate">EndDate</label>
    <div class="col-md-8">
      <input cam-variable-name="enddate"
             cam-variable-type="Date"
             id="enddate"
             name="enddate"
             class="form-control"
             type="date"
              />      
    </div>
  </div>
  
  
  <div class="control-group">
    <label class="control-label">Frequency</label>
    <div class="controls">
      <select cam-variable-name="frequency"
              cam-variable-type="String"
              type="text"
              name="frequency"
              class="form-control"
              >
        <option></option>
        <option value="monthly">Monthly</option>
        <option value="weekly">Weekly</option>
        <option value="once">Once</option>
		<option value="daily">Daily</option>
		<option value="bi-weekly">Bi-weekly</option>
      </select>      
    </div>
  </div>
  
  
  <div class="form-group">
    <label class="control-label col-md-4"
           for="enddate">TrackingCode</label>
    <div class="col-md-8">
      <input cam-variable-name="trackingcode"
             cam-variable-type="String"
             id="trackingcode"
             name="trackingcode"
             class="form-control"
             type="text"
              />      
    </div>
  </div>
  
  <div class="form-group">
    <label class="control-label col-md-4"
           for="enddate">Status</label>
    <div class="col-md-8">
      <input cam-variable-name="status"
             cam-variable-type="String"
             id="status"
             name="status"
             class="form-control"
             type="text"
              />      
    </div>
  </div>
  
</form>

#2

Hi @schilaka, what is this syntax? Can you attach the complete form?


#3

@schilaka please make sure to format code as explained in How to format code blocks?


#4

Hi @schilaka,

The select input field named “target” is set to required… That is why the start button is disabled when the form is loaded. As you select any option, it should get enabled.


#5

Thank you All… I removed the required attribute from Target field. But now the issue with StartDate & EndDate fields. Because when I typed anything in the start date or end date “Start” button is disabled. Could anyone suggest the right syntax of date type in Camunda embedded form.


#6

Hi @schilaka,

have a look into the form reference: https://docs.camunda.org/manual/7.9/reference/embedded-forms/controls/date-inputs/

Cheers, Ingo