All Camunda sample projects using /rest/rest/ API don't work, 404 errors


#1

It seems that all the sample projects that are using a RestApplication in it don’t work on the current Camunda 7.8.0 CE on Tomcat.

I tried, without any modifications:

I have Apache Chemistry running and can connect via CMIS workbench.

But when in the Camunda worklist and trying to upload a document, the rest API endpoint is not found, getting a 404 on:
http://localhost:8080/camunda-invoice-cmis/rest/rest/upload

The same with with the Invoice Box sample project:


There also the /rest/rest/ endpoints all get a 404.

It seems that the javax.ws.rs-annotations @ApplicationPath("/rest"), @Path("/rest") etc. aren’t getting registered properly.


#2

Hey @mathiasconradt
please try to use Wildfly for the two examples.
I will create a ticket in our backlog to make this also work on Tomcat.

Best
Felix


#3

@felix-mueller I had also tested it with the wildfly-distribution with similar results as far as I remember. I will give it another try though.


#4

In the ticket https://github.com/camunda-consulting/code/issues/39
you mention

Update 2:
I just tried with Camunda EE 7.8.0 with WildFly 10. On there, I don’t get a 404 when calling POST /rest/upload but a 505 instead:
org.jboss.resteasy.spi.UnhandledException: java.lang.ClassCastException: org.bouncycastle.pkcs.PKCS8EncryptedPrivateKeyInfo cannot be cast to org.bouncycastle.openssl.PEMKeyPair

This error is most probably related to the box.com java api, so you don’t get a 404 anymore with wildfly.

Best
Felix


#5

Ok. I will try the CMIS example then instead. This way box.com does not get in the way.


#6

Sounds good. Let us know if you face any other issues.


#7

@felix-mueller,

Did you find the time to make it work for Tomcat?

I am struggling to make the cmis invoice snippets work with Tomcat. (I am not implementing the box example and Wildfly).
One of the issues I find is the reference to the rest/upload that does not work. I have made the ajax-load.gif by changing the path from box to cmis.
There is another reference to box I suspect is causing problems in the upload-new.html script.
$(‘input[name=“boxfolder”]’).val(response.uniqueID);
I have tried to change it to “folderName” but it does not work.
I also get the 404 when using the rest/upload url.
Please advise :slight_smile:

Kind regards,
Finn