But then we could keep the old method (not deprecated) - as it still works well and might the better choice if you do not care about the result. This could be reflected in the ApiDocs.
And the new method is used if you do care about the result. That would be somehow intuitive I think.
It is just totally confusing if THE deploy method of the DEPLOYmentBuilder is deprecated. Please don't do that. I already have one slide which looks wired with either the strikedthrough deploy or the new much too long name.
PS: Unfortunately I do not know a better solution for not being able to overload the return type in Java. Sorry. Maybe you could shorten it a bit?