What wersion of modeler should I use with BPMN version 7.10.0

I can not upgrade BPMN engine yet, what is the highest version of modeler I can use?

best regards
Chris

@kku you can use any latest version of modeler,it will work.

But what about DMN v 1.3 from modeler v4 ?

It will work DMN too

But why by modeler 4.0 change log states:
“This release is compatible with Camunda BPM versions 7.13.0, 7.12.4, 7.11.11, 7.10.17 and above.”
?

Modeler is only a tool that visuals for us the bpmn standard, at the end it’s a xml file which an engine reads and do actions. Modeler is only one tool, but there are plenty more and all produces the same xml format.

Check all supported elements by the camunda engine if you are interested in a specific element that you want to use.

Can you upload your BPMN model?

No, I can not upload BPMN model.

I belive that modeler can use syntax/stadard in verison that is, or is not readable by BPMN engine, the same relation about execution model by engine.
What I am looking for is compatibility table camunda modeler verion <-> camunda bpmn verison…

best regards
Chris

1 Like

Hi @kku,

the Camunda Modeler starting with Version 4.0.0 creates DMN diagrams using the DMN 1.3 standard.

If you don’t need DMN in your Camunda BPM Patform 7.10, you can use the latest Modeler.

Otherwise, to create DMN diagrams that you can run in your current decision engine, you need to download a Modeler with version 3.7.0 or less.

BPMN Diagrams are stable, there are no changes in the specification.

You can find the installation files here: https://downloads.camunda.cloud/release/camunda-modeler/

Hope this helps, Ingo

1 Like