Trying to canabalise Underwriting demo


#1

Hi,

I’ve got a copy of the Underwriting demo working on wildfly 10. I’ve then tried to use this as a base for producing a different process app (different BPMN diagram/ different forms).

I’ve compiled and deployed this and I’m able to get to a login page. After entering demo/demo there’s the following error:-

06:46:24,077 ERROR [org.camunda.bpm.engine.context] (default task-9) ENGINE-16004 Exception while closing command context: Cannot deserialize object in variable 'application': SPIN/JACKSON-JSON-01007 Cannot construct java type from string 'com.camunda.demo.underwriting.domain.Application': org.camunda.bpm.engine.ProcessEngineException: Cannot deserialize object in variable 'application': SPIN/JACKSON-JSON-01007 Cannot construct java type from string 'com.camunda.demo.underwriting.domain.Application'
        at org.camunda.bpm.engine.impl.variable.serializer.AbstractSerializableValueSerializer.readValue(AbstractSerializableValueSerializer.java:81)
        at org.camunda.bpm.engine.impl.variable.serializer.AbstractSerializableValueSerializer.readValue(AbstractSerializableValueSerializer.java:27)
        at org.camunda.bpm.engine.impl.persistence.entity.util.TypedValueField.getTypedValue(TypedValueField.java:93)
        at org.camunda.bpm.engine.impl.persistence.entity.VariableInstanceEntity.getTypedValue(VariableInstanceEntity.jav    a:258)
etc. etc.

What I don’t understand is why is the app looking for demo.underwriting? I’ve gone through the project folder and there is no reference to this package anywhere however there is the following message at the bottom of the bunch of messages:-

Caused by: java.lang.IllegalArgumentException: Failed to parse type 'com.camunda.demo.underwriting.domain.Application' (remaining: ''): Can not locate class 'com.camunda.demo.underwriting.domain.Application', problem: com.camunda.demo.underwriting.domain.Application from [Module "deployment.surgical.war:main" from Service Module Loader]
        at com.fasterxml.jackson.databind.type.TypeParser._problem(TypeParser.java:93)
        at com.fasterxml.jackson.databind.type.TypeParser.findClass(TypeParser.java:87)
        at com.fasterxml.jackson.databind.type.TypeParser.parseType(TypeParser.java:50)
        at com.fasterxml.jackson.databind.type.TypeParser.parse(TypeParser.java:36)
        at com.fasterxml.jackson.databind.type.TypeFactory.constructFromCanonical(TypeFactory.java:330)
        at org.camunda.spin.impl.json.jackson.format.JacksonJsonDataFormat.constructJavaTypeFromCanonicalString(JacksonJsonDataFormat.java:160)
        ... 106 more

Can anyone explain what is going on?

your puzzled,

Anthony


#2

Hi Anthony,

Did you start out with a clean database after changing the demo application? If not, the may still be an older process instance that has variables referencing classes of the original underwriting application.

Cheers,
Thorben


#3

Well, it worked kind of. I reset the H2 DB and that didn’t work straight away I also undeployed the underwriting app and that then did work.

If I had done it in 2 separate steps I could tell you which worked but I didn’t so I don’t know what happened to make it work :frowning: