Tasklist: show form fields


#1

Sorry for the newbie question, but that’s what I am :slight_smile:

I’m following the quick-start guide, very useful indeed, and I’m trying to design my own simple processes.

I notice that the provided demo processes, show in the tasklist midlle panel, the form fields, like “Approve Invoice”->“Invoice Creditor”, Invoice Number etc.

I wish to do the same with my own forms, but not all fields are shown. What’s the configuration I have to check to have them visible?

Thank you for your attention,
Ezio


#2

Hello there,
is this topic … off-topic?

:slight_smile: Ezio


#3

Hi @ostorezio,

to show all your variables you have to explicity model an entry for every property in your form and set the entry to “read-only”. In the examples the forms were created as html-forms. You can find them here:

yourCamundaFolder > server > tomcat > webapps > camunda-invoice > forms

If you want to model your forms with the Camunda Modeler instead, you can model a User-Task and specify every entry you want to be visible in the “Forms”-section on the right side.
Check this link to the docs to see all the constraints you can set for your entries, there you can also set your entries to read-only.

Hope that helps

Regards
Michael


#4

Thank you MichiDam for your input,

I added the read-only entry in my form definition, like so … sorry for square brackets …

[div class=“form-group”]
[label for=“Partita IVA”]Customer ID[/label]
[input class=“form-control”
cam-variable-type=“String”
cam-variable-name=“pIVA”
name=“pIVA”
readonly=“true” /]
[/div]

But the field still does not show up in the task list.
There’s not much more I could find in the documentation, so, I think, I’m still missing something.

Ciao,
Ezio


#5

Hi @MichiDahm,

is your form embraced by a form element?

<form role="form" name="form">
...
</form>

Cheers,
Tassilo


#6

Hi Tassilo,

Here’s my complete form definition:
<form name=“processIVA”>
<div class=“form-group”>
<label for=“pIVA”>Partita IVA</label>
<input class=“form-control”
cam-variable-type=“String”
cam-variable-name=“pIVA”
name=“pIVA”
readonly=“true” />
</div>
<div class=“form-group”>
<label for=“customer”>Ragione Sociale</label>
<input class=“form-control”
cam-variable-type=“String”
cam-variable-name=“customer”
name =“customer”
readonly=“true” />
</div>
</form>

With the above definition, the two variable don’t show up in tasklist.
Shoud I add role=form ?

Ciao,
Ezio


#7

Ouch!
After many test and false starts, I’m still having this problem.

I’m running out of options.

Ciao,
Ezio