TaskList in Camunda cockpit loads never stops after adding Swagger OPEN API

@Niall I am stuck here. What I did is just I added in my spring boot application a yaml and I generated the API with Swagger Open API. I dont call anywhere this APIs I just generated them and somehow it is crashing but my APIs are with completely different names so I dont understand why this http://localhost:8080/my-app/camunda/app/tasklist/default/ link does not work. Any ideas?

I can open the Cockpit and whenever I click on Cockpit, tasklist or Admin immediately it is loading and doing nothing. I even dont use this API as I mentioned they are just staying there generated, they are not called in any Delegate etc…

See the photo:

Please provide some additional information on your issue. Usually, some useful things to provide are:

  1. Application server, database, JDK version, etc;
  2. Process engine configuration;
  3. Steps to reproduce the issue or example project.
  4. Any logs/stack traces that are shown when the process is started.

@Niall

  1. Application server SpringBoot, database H2, JDK version 11

  2. Process engine configuration;

    camunda:
    bpm:
    auto-deployment-enabled: false
    database:
    type: postgres
    schema-name: camunda
    # die table-prefix ist nötig, da sonst eine ProcessEngineException durch Camunda geworfen wird obwohl das schema definiert wurde.
    table-prefix: camunda.
    default-serialization-format: “application/json”
    filter:
    create: “All Tasks”
    id-generator: simple
    job-execution:
    enabled: true
    default-number-of-retries: 6
    failed-job-retry-time-cycle: PT1S,PT5S,PT10S,PT1M,PT5M,PT1H
    lock-time-in-millis: 3600000
    queue-capacity: 6
    max-pool-size: 20
    authorization:
    enabled: true
    generic-properties:
    properties:
    general-resource-whitelist-pattern: “[a-zA-Z0-9-_.]+”
    webapp:
    index-redirect-enabled: false

  3. Steps to reproduce the issue or example project
    Just generate the swagger.yaml file and then run as usual the Camunda SpringBoot app. And it did not work with this Swaggen Open Api generated APIs and objects.

.log.txt (17.6 KB)
4. Any logs/stack traces that are shown when the process is started.

So i understand that you’re trying to create a spring boot application for Camunda’s engine, REST AIP and the webapps. This can be done quite easily using start.camunda.com

I’m not too sure what you’re doing with the OpenAPI specification, can you let me know what you’re trying to acheive with it?

@Niall Good morning Niall, do I need this dependency?
org.camunda.bpm.springboot
camunda-bpm-spring-boot-starter-rest

I added it only when I had to do something with SOAP UI but I dont think that without it Camunda should crash… I am trying to find where the problem comes from. Well I am using Swaggen Open Api to generate from yaml file all the REST objects interfaces etc…

Very weird thing happened, I reverted to old version which was working and now it does not work either… I deleted all new jars that I added and still does not work the camunda cockpit is loading loading…

@Niall I dont understand I took a version which was working… and I deleted all jars in my .m2 folder and is still not working I need help for that…

Can you make sure that he version of Camunda matches the version of Spring boot by looking through the Compatibility Chart?

1 Like

@Niall yes they are correct.

<camunda.bpm.version>7.14.2-ee</camunda.bpm.version>

		<!-- Spring Boot -->
		<spring.boot.version>2.3.6.RELEASE</spring.boot.version>

Can you upload the full pom.xml

I am working in an institution where a lot of money comes in… so I cant share that much… I know it is bad but I cant do it. And in the Pom you cant see a lot because there is a repository from which I take the versions etc… of the libraries it is not really simple pom file.

If you’re an enterprise customer you’ll be able to create privet support tickets to Camunda. I suggest you look into that option as it would probably get you more precise help. Let me know if you need any help with that.

@Niall I found the problem, I had to change this, it was Jar Manifest selected… and with this works fine. It was very hard problem to find… thank you again for the support.

1 Like

just for info:

Camunda Cockpit plugin produces 404 error for version 7.11 - Cockpit / Tasklist / Admin & Web - Camunda Platform Forum