Tasklist: form remains open after task completion + 404 error


#1

Hi all,

Normally, when I complete a user task in TaskList, the form instantly disappear and I have no error message on the Javascript console.

For a given step of my BPMN workflow (a user task), I have a weird behavior: when I complete the task in TaskList, the UI form remains open, after a few seconds, a GET request to /camunda/api/engine/engine/default/task/:id is fired, since the task was closed it gets a 404, at this point a blue banner ‘The task has been removed’ appears at the top (with a ‘Close task’ button).

The request response is: {“type”:“InvalidRequestException”,“message”:“No matching task with id 5a47f25d-26c4-11e8-8bb7-acde48001122”}

This happens most of the time. Sometime (10% of the cases), the form is immedialty closed on completion and I don’t get any error message.

What I don’t understand is why this happens specifically for a certain workflow step. After this step I have two service tasks, which get executed without any problem.

Any hints what is wrong with my setup?

I am using Camunda webapp 7.8.0 running inside tomcat 8.0.47.


#2

Something I tried from the problematic user task followed by two service tasks is to add ‘Asynchronous After’ on it to add an additional save point right after it (and decouple it from the following task). Getting exactly the same though…


#3

Hi @pajai,

could you please share your BPMN process file and your user task form when you use an external form?

Do you see any error in the server log file?

Cheers
kristin


#4

Hi @kristin,

I have attached a simplified BPMN process file, which still has the same behavior on the ‘Configuration’ step (form does not get closed, although the two following service tasks are executed sucessfully, then getting ‘The task has been removed’ blue banner + a 404 server request).

I have also attached the external form file (renamed as .xml, since I cannot attach a .html file).

Do you see anything suspicious in the BPMN or form?

process-simplified.bpmn (7.1 KB)

configuration.xml (1.2 KB)


#5

Hi @pajai,

everything looks fine and I can complete the user task Configuration without errors. What are you doing in the next service task? Maybe, you get an exception there and the transaction rolls back?
You could set the async after flag for the user task to be sure that the error is not coming from the other tasks.

Do you see any error in the server log file?
Which camunda version are you using?

Cheers
kristin


#6

Hi @kristin,

No, I don’t get any error from the following service tasks (I can see how they start and finish properly). No error in the server logs, except for the 404 call initiated by the Configuration form staying open in the client.

I tried also setting the ‘async after’ on the Configuration user task. But does not solve the problem (which is logical, since the two following service tasks have no issue).

I am using Camunda 7.8.0.


#7

Hi @pajai,

ok that’s curious…

Could you please share your start form?
Could you see some errors in the console of the browser?

Cheers
kristin


#8

Hi @kristin,

I have attached the start form (again, renamed as .xml). Nothing special in it.

In the browser logs, I see this error (the 404 I was talking about):

Is it working on your side? Which version of Camunda / Tomcat do you use?

Thanks & cheers,


Edit: added the missing start form
start-process-simplified.xml (495 Bytes)


#9

Hi @pajai,

it is working on my side without the start form and I used script task instead of service task. I’m using the same camunda version 7.8.0 (Tomcat 8.0.47).

I think, you forgot to add the start form.

Cheers
kristin


#10

Hi @kristin,

I added the start form in my previous post (sorry!).

I will try to switch the service tasks to a script task, to see if it make a difference…

Cheers,


#11

Hi @kristin,

Weird thing. I downloaded again Camunda 7.8.0 (with Tomcat 8.0.47). And redeployed my two processes from IntelliJ (the standard one and the simplified one you have seen). Fresh db with no old tasks.

I also changed the two following service tasks to script tasks as you did.

But no luck. Still getting exactly the same. The task disappear from the list (middle pane) as soon as I press on complete. But in the right panel, the ‘Configuration’ form remains open + I get a 404 as before. Strange…

There must be something wrong somewhere…

Cheers,


#12

Hi @pajai,

mmhh ok…

How do you deploy your process files? Do you have a spring, web or process application?
Which browser are you using?
Which user are you using for the tasklist login?

Cheers
kristin


#13

Hello @kristin,

we have a similar issue here. Exactly the same versions (camunda 7.8.0 on tomcat 8.0.47).
I also tested with ‘Asynchronous After’ - always the same behaviour.
I also got this with only user tasks in the bpmn, on different browsers (chrome and firefox) and with a ldap server and a postgres attached. I agree with @pajai that in about 10% of the trials it works, in 90% not.

So the question is: when is the task-form closed by the tasklist-app and what could be the reason if it does not.

Cheers
Chris


#14

Hi everybody,

were you able to solve this issue? I encountered it today and can reproduce it 100%.

The problem occurs if I start a process from the Tasklist and then enter the task form by using the popup notification saying “You are assigned to the following tasks in the same process : link to task”. Completing the task now results in the behavior described by @pajai.

If, on the other hand, I enter the task by using the list in the left panel, the task form is closed after clicking the Complete button and no errors are shown in the console.

Maybe this can help to track down the problem.

Cheers
Max