Process not showing up in Cockpit after deployment (Springboot, Jenkins)

Hi at all,
I have a Springboot Application that starts the camunda web app and loads a bpmn in it.
Locally everything worked fine, but when I deployed it to Jenkins, the process was not loaded in the cockpit anymore.
Does anybody have an idea on this?
Thank you :slight_smile:

I finally solved the issue. Two things were going wrong:

  1. I forgot to add extends SpringBootProcessApplication in the Main class. Now it looks the following:
    public class ExampleApplication extends SpringBootProcessApplication{

     public static void main(String[] args){;


  2. I used an empty process.xml in my META-INF folder. However I added the bpmn in the standard process.xml and my issue was solved. My process.xml looks now the following:


        <property name="isDeleteUponUndeploy">false</property>
        <property name="isScanForProcessDefinitions">true</property>


I hope this helps anybody else :slight_smile:

1 Like

Thanks for posting your solution.

1 Like