Migration path for CMMN diagrams available?

I recently created CMMN diagrams with Open Source Modeler V3.1.2 and updated meanwhile to most current version V3.4.1.

Now my CMMN diagrams won’t open anymore, complaining with a “not yet drawn” error.

Any help or advice avaliable?

Best Manfred

Generally, it should still be possible to open CMMN diagrams inside Camunda Modeler version v3.4.1. Can you share your diagram?

Nachlass_Case.cmmn (33.5 KB)

THis CMMN File has been drawn using Modeler 3.1.2 and cannot be opened in newer Modeler 3.4.1

I can’t open your file neither in Modeler version 3.1.2 nor older ones (e.g. 2.2.4). I think the xml of the diagram is broken.

Since the error is caused by the sourceRef of some PlanItemOnPart elements, it should be feasible do remove them in the XML View of the Modeler and renew the connections.

If that worked, can you verify saving and re-open the diagram work then?

Thanks Niklas, this worked and the drawing opened with warnings “no source referenced”. But visual correction is now an easy fix.

BTW, I’ve upgraded now to 3.4.1 :slightly_smiling_face:

Best Manfred

1 Like