Little Typo on method name DeploymentQuery.orderByDeploymenTime()


#1

Hi.

Using api I noticed that the method has probably a typo in the name:
orderByDeploymenTime

shouldn’t be orderByDeploymentTime() ?


#2

Hi Michele,

Good catch. The thing is we can’t simply rename the method as that would break public API. One option is to add a second, correctly spelled method and deprecate the existing one. I personally think this effort is not worth it, but feel free to raise a JIRA issue and/or contribute this.

Cheers,
Thorben


#3

Thanks. I filed an issue in JIRA anyway.


#4

Thats really funny. The “typo” also exists in the Activiti codebase. I guess it’s been around since before Camunda forked Activiti.

Greg