Job executor not picking up jobs

Hello,

I am running Camunda on the standard docker distribution. I have a process that has some timers that create jobs in the ACT_RU_JOB table. I can see the tasks:

# ID_, REV_, TYPE_, LOCK_EXP_TIME_, LOCK_OWNER_, EXCLUSIVE_, EXECUTION_ID_, PROCESS_INSTANCE_ID_, PROCESS_DEF_ID_, PROCESS_DEF_KEY_, RETRIES_, EXCEPTION_STACK_ID_, EXCEPTION_MSG_, DUEDATE_, REPEAT_, HANDLER_TYPE_, HANDLER_CFG_, DEPLOYMENT_ID_, SUSPENSION_STATE_, JOB_DEF_ID_, PRIORITY_, SEQUENCE_COUNTER_, TENANT_ID_
'8f27e53e-ce4d-11e8-8b40-0a58a9feac2a', '1', 'timer', NULL, NULL, '1', '8f25c25c-ce4d-11e8-8b40-0a58a9feac2a', '8f1ee455-ce4d-11e8-8b40-0a58a9feac2a', 'P_OCPE_2:1:1c4c8c3e-cda0-11e8-896d-0a58a9feac2a', 'P_OCPE_2', '3', NULL, NULL, '2018-10-12 18:40:00', NULL, 'timer-intermediate-transition', 'IntermediateCatchEvent_1b8zfqq', '1c28144c-cda0-11e8-896d-0a58a9feac2a', '1', '1c4cb35b-cda0-11e8-896d-0a58a9feac2a', '0', '1', NULL
'8f285972-ce4d-11e8-8b40-0a58a9feac2a', '1', 'timer', NULL, NULL, '1', '8f280c50-ce4d-11e8-8b40-0a58a9feac2a', '8f1ee455-ce4d-11e8-8b40-0a58a9feac2a', 'P_OCPE_2:1:1c4c8c3e-cda0-11e8-896d-0a58a9feac2a', 'P_OCPE_2', '3', NULL, NULL, '2018-10-12 18:40:00', NULL, 'timer-intermediate-transition', 'IntermediateCatchEvent_0qkitty', '1c28144c-cda0-11e8-896d-0a58a9feac2a', '1', '1c4cb35d-cda0-11e8-896d-0a58a9feac2a', '0', '1', NULL

The job executor is running - I can see this in the logs:

18-Oct-2018 22:18:47.052 INFO [Thread-6] org.camunda.commons.logging.BaseLogger.logInfo ENGINE-14018 JobExecutor[org.camunda.bpm.engine.impl.jobexecutor.RuntimeContainerJobExecutor] starting to acquire jobs

However, the jobs remain untouched in the database.

I would like to increase the logging level for the job executor to get a better idea of what’s going on, so I added the following line to the bottom of the file /camunda/conf/logging.properties:

org.camunda.bpm.engine.impl.jobexecutor = FINEST

but I haven’t seen an increase in log messages. Is this the correct way to increase the logging?

Thanks!

Hi,

have you deployed via the REST API and restarted the engine? If this is the case, you need to set the job executor to deployment aware false…

regards

Rob

1 Like

Thanks Rob, we have set the executor to be deployment aware false, but it still does not pick up jobs. I am hoping to set the logging level for the executor in order to see why it is not picking up the jobs.

Thanks again,
David

Hi,

How did you solve this problem… My jobExecutor is also not picking any job… I tried after adding this in Camunda-Tomcat\server\apache-tomcat-9.0.12\webapps\camunda-invoice\WEB-INF\classes\META-INF\processes.xml.
But still it didn’t work…

It turned out to be an issue with our deployment code. We have some code that deploys docker containers and it was not deploying our latest code. In the end setting the executor to not be deployment aware fixed the issue.

Oh, Okay… In my case it is looking different. I just deployed a very simple process and started a lot of process instances to test the load factor. Then I am trying to delete the process instance with a specific business key asynchronously. Batch job gets created and I got 200 response as well. But it gets never picked by job executor. So I am just trying to figure out if I am missing something or doing it in a wrong manner.

Hey, have you found the reason why your job executor doesn´t pick up jobs?
I´ve the same problem (Exception Querying ACT_RU_JOB).

Thx
JW

1 Like