Http Connector

I am using the camunda cloud to use http connector to run a rest api , data modeler on desktop has details-implementation list with connector option, however Connector implementation details is missing in the service task properties on the cloud.

Please advise how to fix this

Hello @vdutt ,

have you used a Cloud BPMN Diagram? There are differences in how each handles implementation details.

image

I hope this helps

Jonathan

Thanks I was able to connect camunda container created on azure.

I am getting a deployment error

ENGINE-09005 Could not parse BPMN process. Errors:

  • One of the attributes ‘class’, ‘delegateExpression’, ‘type’, or ‘expression’ is mandatory on serviceTask.

diagram_3.bpmn (2.4 KB)

diagram_3.bpmn (2.4 KB) error

Hello @vdutt ,

this confuses me right now. In the first post, you mentioned Camunda Cloud. Now, you say that created a Container on Azure.
I can clarify the difference a bit: Camunda Platform is our BPM Platform that you can use and embed inside your own container. It is run with a relational database and most importantly, is available as Community Edition.

Camunda Cloud is a SaaS Solution that comes with high scalability which is only available for Enterprise. It uses another Engine, yet the diagrams have to have different technical extensions.

Which of these are you using right now?

Jonathan

I Started with Camumda Cloud , but the task properties for service task to call a rest point are different on the cloud and i could not find any documentation about it.So i created a Diagram on my Desktop and trying to deploy it on the Camunda Platform azure container .

Hello @vdutt ,

basically, the cloud supports external workers. So if you want to call REST from your process, you have to implement an external worker for could. Maybe @falko.menge can provide a useful resource here.

On the other hand, if you are working with Camunda Platform, you need to use the modeler and create a diagram for Camunda Platform. Here, you can find all important information in the Docs:

https://docs.camunda.org/manual/latest/

I hope this helps.

Jonathan

Thanks Jonathan
I am trying to deploy diagram from modeler and diagram_3.bpmn (2.5 KB) getting a deployment error

ENGINE-09005 Could not parse BPMN process. Errors:

  • One of the attributes ‘class’, ‘delegateExpression’, ‘type’, or ‘expression’ is mandatory on serviceTask.

Hello @vdutt ,

I tried to do the same and I also ran into trouble. What then came to my mind:

By default, all connector are installed but not the plugin itself. You will need the following dependency inside your platform:

<dependency>
  <groupId>org.camunda.bpm</groupId>
  <artifactId>camunda-engine-plugin-connect</artifactId>
</dependency>

If you use Camunda Run, paste a jar file of the dependency inside the userlib folder.
This should make it work (in my case, it worked).

Jonathan

While Deploying from Data Modeler , i am attaching below jar files

camunda-connect-core-1.2.2.jar
camunda-connect-connectors-all-1.0.0.jar

Hello @vdutt ,

when using Camunda Run, you will need to modify the image in the above explained way. The name of the jar is then camunda-engine-plugin-connent-${version}.jar.

Jonathan

I copied below jar files to /camunda/configuration/userlib , still same error

-rw-r–r-- 1 camunda camunda 1584250 Jul 16 15:00 camunda-connect-connectors-all-1.5.2.jar
-rw-r–r-- 1 camunda camunda 9251 Jul 16 15:00 camunda-engine-plugin-connect-7.15.0.jar
-rw-r–r-- 1 camunda camunda 19149 Jul 16 15:02 camunda-connect-core-1.5.2.jar

Ok @vdutt ,

I see 2 ways now:

  1. We ask @Niall for help to configure Camunda Run with Connectors
  2. You implement the Rest Call on your own (as External Task for example)

Jonathan

1 Like

@Niall Please advise how to resolve this issue

Before trying to configure connectors with Camunda Run (which isn’t too easy)
i suggest you look at this project for other options

4 Likes

I have installed Camunda Enterprise and i was able to deploy the diagram when i am running the http_connector i am below error.

“error”: “Bad Request: 400 Bad Request: The browser (or proxy) sent a request that this server could not understand.”

How do i get the command being executed (just to make sure correct parameters & headers are passed)? i check the logs could not find it.

@ Jonathan Lukas Please advise

Hello @vdutt ,

have you adjusted the log level of your platform so that it logs all platform activity?

Sorry for the late answer.

This should make the http-connector log visible. Otherwise, direct the HTTP Request towards a proxy that logs it.

Jonathan

How do we adjust log level?

@ Jonathan Lukas pls advice

Hi @vdutt
Can you be more patient when waiting for a response.
No need to post more than once. People will help you out when they can.

1 Like