How to use external libraries in embedded forms (Tasklist)


#21

Hi @hassang,

Here are all related files:

config.txt (1.6 KB)
loadSimpleMDE.txt (103 Bytes)
sample-form.txt (379 Bytes)

I didn’t upload the simplemde.min.js, because its an official js file.

The locations of the files in the deployed webapp are:
config.js: /camunda/app/tasklist/scripts
loadSimpleMDE.js: /camunda/app/tasklist/scripts
simplemde.min.js: /camunda/app/tasklist/scripts
sample-form.html: located in the external process application and referenced as a startform for a bpmn process

So please have a look on the files, if something is wrong or missing :slight_smile:

Best regards
Marvin

PS: I had to convert them to txt, because it’s not allowed to upload html or js files.


#22

Did you clean the history of the browser?


#23

Yes, I cleared my whole history and the cache, but without any effects.


#24

What is the exact error message now?
What is the browser you are using?
I am using Google Chrome


#25
  1. Form failure: simplemde is not defined
    I don’t see any other errors in the Developer Console or in the Network traffic
  2. I tried it on Google Chrome, Internet Explorer and two different versions of Firefox, but all get the same error message.

#26

The only thing I can think about is your simplemde.min.js file…
Can you please make sure that your content is identical to the original one?
Recopy the content of it… please…


#27

Hi @hassang,

It works :slightly_smiling_face:

In the end you post: How to use external libraries in embedded forms (Tasklist) suddently works, I’m not sure why it was not working before, maybe because I didn’t cleared the cache at this point of the conversation.

So thanks a lot for all your assistance :smiley:

Best regards
Marvin