Getting error while deploying the model to Camunda hosted on PCF


#1

Hello All -

I am getting the below error while deploying the bpmn file to Camunda instance hosted on PCF(on-prem). It looks like a certificate issue and I will have to work on the certs related issue on my own, but, I am also looking to see if someone else got the same error too and if so how did you fix it.

Deploy error: {“code”:“UNABLE_TO_VERIFY_LEAF_SIGNATURE”,“deploymentName”:“demo”,“errno”:“UNABLE_TO_VERIFY_LEAF_SIGNATURE”,“message”:“request to https://apps.system..*****.**********.int/engine-rest/deployment/create failed, reason: unable to verify the first certificate”,“type”:“system”} [deploy-error]

Thanks in advance
Dheeraj.


#2

Hello Dheeraj,

I’ve ran into the same issue. Proper solution would be to get Camunda Modeler to trust your server side certificate but I didn’t find any solution for that.

What I found as a workaround instead is that you can get Camunda Modeler to trust any certification (i.e. disable SSL certificate validation). To do that you need to set the following system property:

NODE_TLS_REJECT_UNAUTHORIZED=0

You can create a script file on windows with:

set NODE_TLS_REJECT_UNAUTHORIZED=0 (export NODE_TLS_REJECT_UNAUTHORIZED=0 on linux)
“Camunda Modeler.exe”

And save it where you “Camunda Modeler.exe” is.

Running the script should do the trick.

Michal


#3

Thank you Michal. We will try this solution and see how it goes.