Form buttons rename


#1

Hey,

is it possible to rename the buttons complete in a form.

I only found this https://forum.camunda.org/t/replace-complete-with-approve-reject-buttons/1737. Is it still actual to change something in the .css file?


#2

Hi @xAJ,

yes you can change the displayed names.
in the Tomcat-Bundle you can go to the folder:

camunda-bpm-tomcat-x\server\apache-tomcat-x\webapps\camunda\app\tasklist\locales\en.json

There you search for the entry “COMPLETE”. In this field you can set the text that is displayed to complete a form.

Hope this helps

Regards
Michael


#3

Hi @MichiDahm

The path sounds great and I changed the value but nothing happened in camunda tasklist. I restarted my Tomcat, and still no change, so I don’t know why camunda is not updating it.


#4

@xAJ,

I had the same problem a few times. I guess the browser is sometimes caching some parts of the page.
But reloading everything with Ctrl+F5 mostly did the trick for me :grinning:


#5

@MichiDahm

Yeah Crtl + F5 did not helped :smiley: I cleared my hole cache in the browser and now it works.

Thanks


#6

@xAJ

glad to hear that it worked. :grin:

Maybe the behaviour of refreshing the content and the cache is depent on the browser that you use.
For Chrome it always worked for me with Ctrl+F5 or Shift+F5.


#7

@MichiDahm

I’am using a mac with chrome maybe the os is doing something with the browser.
Ctrl + F5 is not working for me I have to press cmd + Shift + r :sweat_smile:


#8

Hey,

is it possible to rename it for each bpmn or task?


#9

Hi @xAJ,

what exactly do you mean with that?


#10

@MichiDahm

i want for each task a different name for the complete button. For example I have another process where my renamed complete button is not fitting anymore so i want a different name for the button (complete)
but I don’t want to rename for the hole camunda application only for a specific part.


#11

@xAJ

I would suggest that you don’t go for an approach like this.

If you want to achieve, that every task has its own button name, you need to implement that logic on your own.

I guess that adding this functionality seems like a lot of overhead for such a small feature. The best is, if you set one name for the button and stick with that.

Regards
Michael