Error creating bean with name 'metadataService'

Hi Nel ,
I am new in camunda .one month back i start working on camunda . I want to use the Camunda Optimize.
I have download the software and installed it. I am able to connect my local camunda bpm.I want to connect the Dev environment camunda BPM through Optimize .Please help me or provide me the document to configure my local optimize to connect dev bpm .Need proper configuration document where i can create use so optimizer user can connect bpm and access the data to build the report.

regards
brajendra

HI @brajendra.kumar

happy to hear that you are trying out Optimize.
Have you followed the installation guide: https://docs.camunda.org/optimize/latest/technical-guide/setup/installation/ ?
What are your issues? Can you share your configuration and shed a bit more light on your setup?
What have you downloaded, installed? What are you running, etc.

Best
Felix

1 Like

thanks for the installation guide .let me explain what i did and what i want to do it.
I have downloaded the optimize software and as per imnstallation guide line instruction i have first executed .\optimize-demo.bat after that i executed .\optimize-startup.bat then i am able to login to optimize.Camunda optimize is able to fetch all process definition of my local camunda bpm
.I want to configure my optimize to connect my External camunda bpm(host) and fetch all process.
how to configure to connect remote system camunda bpm.please provide my doc.

HI @brajendra.kumar
you can find the configuration options here:

https://docs.camunda.org/optimize/latest/technical-guide/setup/configuration/#connection-to-camunda-bpm-platform

You need to change the engines.${engineAlias}.rest so that it points to your remote camunda engine.

Best Regards
Felix

Am not able to connect the remote camunda system .can u please give me sample configuration file to configure below parameter
engines:

An alias of the engine, which will be used for internal purposes like

logging and displaying which data belong to which engine.

‘camunda-bpm’:
# The name of the engine that will be used to import data.
name: default
# A base URL that will be used for connections to the Camunda Engine REST API.
rest: ‘http://localhost:8080/engine-rest’
authentication:
#Toggles basic authentication on or off. When enabling basic
#authentication, please be aware that you also need to adjust the values
#of the user and password
enabled: false
#When basic authentication is enabled, this password is used to
#authenticate against the engine.
password: ‘’
#When basic authentication is enabled, this user is used to authenticate
#against the engine.
user: ‘’
# The webapps configuration allows Optimize to directly link
# to the other Camunda Web Applications, e.g. to jump from
# Optimize directly to a dedicated process instance in Cockpit
webapps:
# Defines the endpoint where to find the camunda webapps
endpoint: ‘http://localhost:8080/camunda’
# Enables/disables linking to other Camunda Web Applications
enabled: true

es:

A hostname on which the Elasticsearch TCP listener is available.

host: localhost

The name of the Elasticsearch cluster Optimize should connect with.

clusterName: elasticsearch
ports:
# A port number used by Elasticsearch to accept TCP connections.
tcp: 9300
# A port number used by Elasticsearch to accept HTTP connections.
http: 9200

An index name used to create all Camunda Optimize types, shards, etc.

index: optimize
settings:
index:
# How often should the data replicated in case of node failure.
# NOTE: this property only applies the first time Optimize is started and
# the schema/mapping is deployed on Elasticsearch. If you want to take
# this property to take effect again, you need to delete all indexes (with it all data)
# and restart Optimize.
number_of_replicas: 1

  # How many shards should be used in the cluster.
  # NOTE: this property only applies the first time Optimize is started and
  # the schema/mapping is deployed on Elasticsearch. If you want to take
  # this property to take effect again, you need to delete all indexes (with it all data)
  # and restart Optimize.
  number_of_shards: