Element Templates not Appearing (Mac OSX)


#1

Hello,

I’m trying to configure some Element Templates in the Camunda Modeler to mimic some of the functionality we had with custom tasks in the legacy Eclipse plugin. I downloaded a fresh Camunda Modeler from the website, and it got put under the ‘camunda-modeler’ directory. Also under this directory, I created a ‘resources’ directory, followed by an ‘element-templates’ directory under that.

In that newly created ‘element-templates’ directory I created an ‘elements.json’ file, into which I copied the first example json file from the Camunda Element Templates webinar (https://vimeo.com/172081069), which creates a Element Template for Service Tasks. I re-started the Camunda Modeler, opened up a simple .bpmn file with a Service Task, and clicked on that task, expecting to see the Element Templates drop-down menu on the Properties Panel, like was seen in the webinar. However, the panel looked the same as before. No drop-down menu.

Does anyone have any ideas as to what could be going wrong here? Is there something incorrect about my approach? I tried to follow the steps in the github documentation and the webinar as exactly as possible, but the menu still doesn’t appear.

Thanks for your help,
Matthew


#2

Hi @mluebbers,

did you add a JSON file for the element template to the ~/Library/Application Support/camunda-modeler/resources/element-templates folder, as described in the Element Template documentation 1?

Cheers,
Mat


#3

Hi Mat,

I did previously try adding the JSON to that directory with no success earlier, but it seems it got overwritten when I downloaded the latest Camunda modeler. I re-added the file to that directory, and it appears to be working now! Thanks for your help.

For future reference, is this the only directory that needs the JSON file for the element templates? Do I need to also put it under the directory with the Camunda Modeler application like was seen in the webinar, or no?

Best regards,
Matthew


#4

According to the docs you can either put it there - allowing the use for all models (where the type matches) on your machine or place it in the source directory (anywhere in the path tree) - which is likely what you want if you have the models under version control.