Deploy Error - Unexpected '<' in Json at response body

Can you upload your model?
Also could you use a more recent version of the modeler, 3.7.0 is already out - you can download it here:

Thanks Niall.

(note that during the post, I drop the portion ‘http://’ from links, otherwise the web system rejects my post, as new user can just use two links)

About Modeler release 3.7.0, I installed it. Its deployment modal form is a little bit different, anyway it reads ‘Could not find the Camunda endpoint. Please checl the URL and make sure Camunda is running’
with the following endpoint hint ‘localhost:8080/rest’ which is different from the one proposed by Modeler 2.0.0 (‘localhost:8080/engine-rest/deployment/create’)
However, with each of them, the botton Deploy remains disabled (and also with a mix, as ‘localhost:8080/rest/deployment/create’)

Please, explain the conditions to have Deploy button enabled. Does it happen even before writing login information (Authentication, etc.) ? Unfortunately, documentation from docs.camunda.org/get-started/quick-start/deploy/ hints ‘engine-rest’.

About uploading the model, is there a way to attach to the post ?:

Yeah - it’s annoying and confusing but for now:

localhost:8080/rest/deployment/create
If you’re deploying to the springboot distro

localhost:8080/engine-rest/deployment/create
If you’re deploying to any other distro (tomcat, wildfly etc.)

You need to make sure that you have the platform running in one way or another before deploying. Depending on how you’re setup the distro authentication may be required.

I deployed Camunda community edition to tomcat environment.

Anyway, using localhost:8080/engine-rest/deployment/create, Deploy button is not enabled and the warning about endpoint remains. I suppose it is the correct endpoint since modeler 2.0.0 was able to send the deployment request using it.

About the model, can I attach it somewhere ?

Thanks for your support.

You should upload your model to the forum.
Or upload your project to github and link to it.

Hi @mauro,

the latest version of the modeler adds /deployment/create automatically.

You just have to choose between http://localhost:8080/engine-rest or http://localhost:8080/rest.

You should take the first one.

Hope this helps, Ingo

Mine latest version, 3.7.0 (26th of Feb 2020) did not add it automatically.

I tried both localhost:8080/rest/deployment/create and localhost:8080/engine-rest/deployment/create, but Deploy button remains disabled with each of them.

Any hint about possible causes ? Modeler 2.0.0 worked with “engine-rest” case (I use tomcat).

explain what you mean by this and also please upload your model.

Yes Niall, the Deploy button remains disable, I cannot press it, either if I use the path with ‘engine-rest’ or if I use the path with ‘rest’.

Thanks

What does the error message say?

The same as wrote above:

‘Could not find the Camunda endpoint. Please checl the URL and make sure Camunda is running’
(in the ‘Endpoint Configuration’ section)

It appears on the deplyment form before I can try to press Deploy button (but I can try to change the path).

Have you started Camunda up?
Are you able to open up this URL? - localhost:8080/camunda

Oh yes, I was just going to add this note.

The first attempt was I accessed again to the Camunda URL and it worked fine.

Well, I am going to try to close and reopen Tomcat, too.
I’ll write you in a while.

Thanks.

Interesting note: while Tomcat/Camunda are down, the message changes:

‘Could not connect to the server. Did you run the engine?’
alternating with attempts to ‘Validation connection…’

After Tomcat/Camunda restart, the message is the same as earlier, hence with Deploy button disabled, too.

Additional note: after installing Camund community edition, I did NOT change any configuration (database, LDAP, etc.). I am trying first to be able to store process definitions, and learn to work on Camunda world.

hi @mauro,

just to clarify my comment:

in the background.

If you enter http://localhost:8080/engine-rest, the button should be enabled.

Hope this helps, Ingo

Yes, it was clear.

Nevertheless, in my case, it does not :frowning:

Other options /configurations to check somewhere ?

Thanks

Is it the case I download and try camunda 7.13 alpha release ?

As minor, is there a way to save the “REST endpoint” as old Modeler 2.0 does,
so avoiding to newly write anytime the addition “/deployment/create” ?

Anyway, if Ingo states that this addition is automatic in latest modeler version,
can you guess why in my case it does not happen ?

Thanks a lot for any support.

Hi Niall,

please see at this link both the modeler files and the error screenshot.

Note also that after I open (in Modeler 3.7.0) the file produced by Modeler 2.0.0, and then saved it, there was no change in the file.
I suppose this would mean that JSON error will appear again even after resolving the question of the REST Endpoint.

Can this hint help to you to think about some check to advising me in veryfing some Camund configuration, installation paht, or any else ?

Thanks for your support.

By then, I suppose that when I said

“Modeler 2.0.0 worked with “engine-rest” case (I use tomcat).”

I was wrong. Maybe it was an error caused by the lack of responses from the REST endpoint,
which has been better diagnosed by laster Modeler version.

I also tried to manually type that path ‘…engine-rest…’ in a browser, and I have confirmation that there is no answer, in the sense that ‘error 404’ is retrieved, but I am not sure if this additional test makes sence.

So… what to check about Camunda configuration ?

My installation process was to copy the (standalone 7.12) .war file (renamed into 'Camunda.war) in the “webapps” directory of my tomcat (in xampp 7.4.2.0),
while tomcat itself was not running, and then I restarted tomcat.
Note that accessing camund works fine in browsers (http://localhost:8080/camunda/).

Any idea about REST interface, please ?

Maybe the answer is in

where Yana user explained about a different path to be used.
I will open a new post about credentials.

Anyway, thanks for help and support.