Change thread pool timing


I have integrated Camunda into spring boot application.
I have a TimerCatchingEvent which is set to PT2M, 2 minutes. But the service task after the timercatching event doesn’t gets triggered exactly after 2 minutes. It takes around 2 minutes and 20-30 seconds extra.
My application is very critical when considering time and can’t afford to have to those extra 20-30 seconds.

How can i change the task executor timing configuration?

Help is much appreciated.


I have done below but still no luck

public class CamundaConfiguration {

public TaskExecutor camundaTaskExecutor() {

    final ThreadPoolTaskExecutor threadPoolTaskExecutor = new ThreadPoolTaskExecutor();


    return threadPoolTaskExecutor;


Hi @ash6892,

most probably the wait time between job acquisitions is too long because of low amount of jobs to do.

You can contol the wait time between job acquisitions with camunda.bpm.job-execution.max-wait: 5000 or less. Have a look at the configuration options for spring boot: and the backgroud of job execution: You can find all job acquisition configurations at:

Hope this helps, Ingo