Cannot start Camunda Tomcat


#1

Hi,

I had downloaded Camunda-bpm-tomcat-7.5.0 distribution and it was working until I rebooted my laptop.
I run the start-camunda.bat file but it’s not connecting to http://localhost:8080/camunda-welcome/index.html

Any ideas what went wrong? Where should I troubleshoot?

Thanks


#2

Hi @kontrag,

could you check out tomcat logs if there is an error?
Can you open http://localhost:8080/camunda/app/tasklist/default ?

Cheers,
Askar


#3

Hi @aakhmerov,

camunda-bpm-tomcat-7.5.0\server\apache-tomcat-8.0.24\logs folder is empty.
No, I cannot open that link either.


#4

@kontrag,
are you running windows or linux? is tomcat process running? on linux ps -ef | grep tomcat. On Windows check in task manager.

Cheers,
Askar


#5

I’m on windows, this is what I get when I run the start-camunda.bat

But in the browser, I cannot connect localhost.


#6

@kontrag,

could you check in task manager if tomcat process is running? Or on command line tasklist | FIND "tomcat". If it is running please kill it and start again.

Cheers,
Askar.


#7

What should I look in task manager for? javaw.exe? I don’t see it.
Your command line doesn’t return anything.


#8

@kontrag,

ok so that means that tomcat is not starting for some reason. I see that you are using JRE_HOME, could you please install JDK and set JAVA_HOME environment variables?

Cheers,
Askar.


#9

I had already installed JDK and JAVA_HOME environment variable is set.


#10

@kontrag,

then your tomcat is not using it for some reason. Please check your startup scripts if it’s overriden somewhere, if not then try inlining it there and see if that helps.

Cheers,
Askar


#11

@aakhmerov

Thanks for your time first of all!!

I removed JRE_HOME from my User Variables and now it points to JDK and works.
But, for my understanding, which one does Tomcat need to run properly?
What if I want to set JRE_HOMe as a user variable for another reason?

Cheers


#12

Hi @kontrag,

I think officially it needs JRE only. But JDK has some additional tools and libraries which are required for parts of functionality. As a rule of thumb, just use JDK unless it’s really important for you to use JRE.

You can read more explanations here:

Cheers,
Askar


#13

In the first screenshot I posted, you can see that Tomcat was using
JRE_HOME= C:\Progra~1\Java\jre1.8.0_111
which was taken from the User Variables.

What I did to make it work was to add the following line in the ~camunda-bpm-tomcat-7.5.0\server\apache-tomcat-8.0.24\bin\setenv.bat

set “JRE_HOME=%ProgramFiles%\Java\jdk1.8.0_111\jre”

My question is: Is it fine that the JRE is taken from within the JDK folder? And not from its own JRE folder as the screenshot?

Thanks!


#14

Hi @kontrag,

yes, that’s fine.

Cheers,
Askar.


#16

If people still have issues, it might have to do with your java 9 installation. The default bundled tomcat will not work on Java 9. You will have to downgrate to java 8, or install a more recent Tomcat installation.

See https://stackoverflow.com/questions/45917401/tomcat-7-0-73-doesnt-work-with-java-9 for more info.


#17

Gosh! I could kiss you right now!!! thanks a lot! this solved it for me!!! :hugs::hugs::hugs::hugs::hugs: