Camunda REST engine


#1

Hello fellas,

I have an issue with Camunda deployment. Everything work fine but REST engine. By some reason, I cannot access it (having 404 HTTP error “not found”), please see an image attached.

Can you suggest what could possibly be wrong?
I have installed Camunda from Pre-Packaged distribution, latest version.


#2

Hi,

check your URL. From the REST docs reference;

The default process engine is available out of the box by accessing /engine-rest/engine/default/{rest-methods} or simply /engine-rest/{rest-methods}. Any other shared (i.e., it is globally visible) process engine that is created later is available through /engine-rest/engine/{name}/{rest-methods} without any further configuration.

Hence you may want to use ‘/engine-rest/engine/default/’ or ‘/engine-rest/’

regards

Rob


#3

Neither of these way works. I actually tried all this before.


#4

Hi
Can you post the URL you are trying and the operation you want to perform?

Rob


#5

Right now I’m trying to see if it works at all by accessing it by http://localhost:8080/engine-rest/engine/default/


#6

Ok,

Your URL will give a 404 as this is just the base URL and it is missing a ‘command’. You can get a list of defined process engines with this URL;

http://localhost:8080/engine-rest/engine/

With this you should get an http 200 and a json structure listing engine names…

regards

Rob


#7

It does not work. Please see the screenshot from my initial question. Using this address (or any other from documentation) gives 404 (Not found). I assume there is something wrong with the service as such. Any ideas where I can see log data for REST engine?


#8

@Commandor, does the server log show that the REST API was successfully deployed? Did you rename any files or folders or change any configuration settings of the default distribution?

Cheers,
Mat


#9

From Tomcat App Manager I can see /engine-rest is deployed and running. Tried to re-deploy it - the result is the same. I use Pre-Packaged distribution, so everything I change was connection data for SQL Server db, that’s it.


#10

Re-deployed everything from scratch. Now, if I call http://localhost:8080/engine-rest/engine/ it gives “[{“name”:“default”}]” json response. Does it mean it works ok?


#11

Yes!
Thait’s what you get by default.


#12

@Commandor,
as @langfr mentioned, yes, that’s what you get by default. The call http://localhost:8080/engine-rest/engine/ returns a list of all process engines available on your platform. See the documentation for details: https://docs.camunda.org/manual/7.7/reference/rest/engine/get-names/

Cheers,
Mat


#14

This one is the correct war to download