Camunda optimize with Camunda spring boot do not show processes


#1

I use Spring boot with Camunda ( version 3.2.1). I see that camunda rest api is localhost:8080/rest( for example localhost:8080/rest/process-definition/key/LightPath_CreateNew/start ).

I download Camunda enterprise trial ( 7.10.0).
I start Camunda Optimize successfully and login. However, when I go to New Report and try to select a process to create report , no processes are available. In Camunda, 5 processes are running. I can see processes in Cockpit.

How I can overcome this problem?

My configuration in environment-config.yaml is :

engines:
‘camunda-bpm’:
# The name of the engine that will be used to import data.
name: default
# A base URL that will be used for connections to the Camunda Engine REST API.
rest: ‘http://localhost:8080/rest
authentication:
#Toggles basic authentication on or off. When enabling basic
#authentication, please be aware that you also need to adjust the values
#of the user and password
#Also note, when enabled, it is required that the user has read history permission
#on the process/decision definition resources to enable Optimize to import the engine data.
enabled: true
#When basic authentication is enabled, this password is used to
#authenticate against the engine.
password: ‘xxx’
#When basic authentication is enabled, this user is used to authenticate
#against the engine.
user: ‘xxx’
# The webapps configuration allows Optimize to directly link
# to the other Camunda Web Applications, e.g. to jump from
# Optimize directly to a dedicated process instance in Cockpit
webapps:
# Defines the endpoint where to find the camunda webapps
endpoint: ‘http://localhost:8080
# Enables/disables linking to other Camunda Web Applications
enabled: true


#2

Hi @cgeorg

happy that you are trying to play around with Optimize!

A couple of question so that I can try to help you here:

  1. Can you share the Optimize logs with us?
  2. Does the user you are using for the import have enough permissions? Are you using an admin user for the import? (The one you configure in the environment-config.yaml).

Best
Felix


#3

The problem was authorization issue. I correct .yaml in Spring boot and everything is working fine.
Thanks for the advice.


#4

Happy to hear that it works now!