An issue of upgrading 7.7 to 7.8


#1

I am upgrading from 7.7 to 7.8. The database is postgresql. My camunda engine has to run when deploying the db schema changes. A new column is added into act_hi_varinst table. I got errors for current running tasks: cached plan must not change result type, and current transaction is aborted. I tried to set the autosave to conservative, still got errors.

I wonder if I have to bring process engine offline when upgrading camunda?

Thanks

Sample errors:
2019-02-08 06:29:36 UTC:205.251.233.176(29562):sa@camunda:[736]:ERROR: cached plan must not change result type
2019-02-08 06:29:36 UTC:205.251.233.176(29562):sa@camunda:[736]:STATEMENT: select * from ACT_HI_VARINST where ID_ = $1
2019-02-08 06:29:36 UTC:205.251.233.176(29562):sa@camunda:[736]:ERROR: current transaction is aborted, commands ignored until end of transaction block
2019-02-08 06:29:36 UTC:205.251.233.176(29562):sa@camunda:[736]:STATEMENT: select * from ACT_HI_VARINST where ID_ = $1


#2

Hi @yanyunsong,

According to https://stackoverflow.com/questions/2783813/postgres-error-cached-plan-must-not-change-result-type, it looks like you can change a JDBC driver setting to tolerate this schema change.

Cheers,
Thorben